Inhalte aufrufen

Profilbild

DB error after update to v5.1.0

"\r\n48574 "Fehler nach Update 6.3.5

  • Bitte melden Sie sich an, um eine Antwort zu verfassen.
2 Antworten zu diesem Thema

#1 nickh

nickh

    Erfahrener Benutzer

  • Members
  • 128 Beiträge

Geschrieben: 08 February 2024 - 15:37

Hi.  I'm currently running V5.0.5 and when I attempt to upgrade to V5.1.0 I get the following error message when the site starts up:

 

Controller: Error, Action: Error, Status: 500 (InternalServerError)

Incorrect syntax near '$'.

 

If I remove the App_Data Settings.txt file, it creates a new DB and the site looks fine, but I want to use my existing DB.  I had a look for any obvious differences between the newly created DB and my existing one (which worked absolutely fine with V5.0.5), and I noticed that the collation is different: the old DB has a collation of Latin1_General_CI_AS but the new one is SQL_Latin1_General_CP1_CI_AS.  Also the "Compatibility level" is different, although I'm not sure how this could relate to the above error.

 

Is this a known breaking change?  If the collation difference isn't to blame, what else could I try?  There is nothing logged to the event viewer about this.



#2 Artar

Artar

    SmartStore AG

  • Administrators
  • 988 Beiträge

Geschrieben: 08 February 2024 - 16:30

Please check and update the compatibility level of the database.
A current date is ideal


  • nickh gefällt das

Zihni Artar
SmartStore AG


#3 nickh

nickh

    Erfahrener Benutzer

  • Members
  • 128 Beiträge

Geschrieben: 09 February 2024 - 10:56

Thanks Artar, that has fixed it.


  • Artar gefällt das


Auch markiert mit einem oder mehrerer dieser Schlüsselwörter: "\r\n48574, "Fehler nach Update 6.3.5