Inhalte aufrufen

Profilbild

Reverse Proxy - Bilder funktionieren nicht mehr

Reverse Proxy Media Port

Best Answer Marcus Gesing , 23 December 2020 - 16:29

Konfiguration > Medien > Deaktivieren von Absolute URLs erzeugen.

Go to the full post


  • Bitte melden Sie sich an, um eine Antwort zu verfassen.
1 Antwort zu diesem Thema

#1 neuhausf

neuhausf

    Newbie

  • Members
  • 1 Beiträge

Geschrieben: 23 December 2020 - 10:28

Guten Tag!

Wir verwenden einen Reverse-Proxy (nginx), welcher dem Webserver (IIS) vorgeschaltet ist. Das funktioniert eigentlich auch gut, bis auf ein wichtiges Detail:

 

Medien (Bilder) werden nicht dargestellt. Das Problem liegt daran, dass die Bilder immer mit einer Portangabe abgerufen werden, die so nicht funktioniert.

 

Shop-Konfiguration

Url: => https://meinshop.de/

SslEnabled => 1 (ein)

SecureUrl => https://meinshop.de/

Hosts => meinshop.de, www.meinshop.de

ForceSslForAllPages => 1

 

Reverse Proxy nginx:

Leitet von meinshop.de weiter auf 192.168.1.x:50000 (interner IIS Server)

 

IIS:

Binding für http, Port 50000 eingerichtet

 

Seite wird bis auf hochgeladene Bilder korrekt dargestellt. Bilder werden mit folgender URL abgerufen:

https://meinshop.de:50000/media/18/catalog/meinbild.jpg?size=256

 

Die Portangabe muss weg. Wie kann ich das konfigurieren?

 


  • stefanmueller gefällt das

#2 Marcus Gesing

Marcus Gesing

    SmartStore AG

  • Administrators
  • 3661 Beiträge

Geschrieben: 23 December 2020 - 16:29   Best Answer

Konfiguration > Medien > Deaktivieren von Absolute URLs erzeugen.


  • stefanmueller und neuhausf gefällt das

Schöne Grüße aus Düsseldorf,
Marcus Gesing



Auch markiert mit einem oder mehrerer dieser Schlüsselwörter: Reverse Proxy, Media, Port