Inhalte aufrufen

Profilbild

Different versions on the same web server

different versions V8JsEngine JavaScriptEngineSwitcher

  • Bitte melden Sie sich an, um eine Antwort zu verfassen.
Keine Antworten zum Thema vorhanden

#1 Wlady

Wlady

    Advanced Member

  • Members
  • 69 Beiträge

Geschrieben: 29 November 2020 - 15:24

Dear developers!
Is it possible that instances of different versions of SmartStore cannot run on the same web server? We have version 3.2. run and now the version 4.1 installed. It was harvested at the start of 4.1. the exception:

 

During loading of the Autoprefixer error has occurred. Failed to create instance of the V8JsEngine. Most likely it happened, because the 'v8-x64.dll' assembly or one of its dependencies was not found. Try to install the JavaScriptEngineSwitcher.V8.Native.win-x64 package via NuGet. In addition, you still need to install the Microsoft Visual C++ Redistributable for Visual Studio 2019 (https://visualstudio...ual-studio-2019).

Failed to create instance of the V8JsEngine. Most likely it happened, because the 'v8-x64.dll' assembly or one of its dependencies was not found. Try to install the JavaScriptEngineSwitcher.V8.Native.win-x64 package via NuGet. In addition, you still need to install the Microsoft Visual C++ Redistributable for Visual Studio 2019 (https://visualstudio...ual-studio-2019).

Cannot load V8 interface assembly. Load failure information for v8-x64.dll: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\5775b716\87d86cf\assembly\dl3\6d53f765\1c024499_63c5d601\x64\v8-x64.dll: Das angegebene Modul wurde nicht gefunden D:\MojDom\x64\v8-x64.dll: Das angegebene Modul wurde nicht gefunden D:\MojDom\bin\x64\v8-x64.dll: Die angegebene Prozedur wurde nicht gefunden

 

If, but, the instances of verse 3.2. are stopped, the new version 4.1. runs without problems. When activating version 3.2 again, errors occur in this.

 

Greetings Wlady