Inhalte aufrufen

Profilbild

Keine Anmeldung als Admin möglich - Version 4.0.1


  • Bitte melden Sie sich an, um eine Antwort zu verfassen.
6 Antworten zu diesem Thema

#1 msg team bauch

msg team bauch

    Newbie

  • Members
  • 5 Beiträge

Geschrieben: 10 August 2020 - 13:18

Guten Tag!

 

Ich kämpfe nun seit einigen Tagen mit der Installation der Version 4.0.1. Das ist eigentlich ja auch sehr einfach. Die neue Version habe ich mehrmals auf den Server kopiert, aber immer wieder hat der Aufruf des Shops nicht funktioniert. Zwischen dem ganzen kopieren hbe ich immer wieder die Datensicherung vom alten Shop kopiert und auch die Datenbank wieder hergestellt.

 

Jetzt endlich kann ich den Shop aufrufen, nur leider kann ich micht nicht anmelden. Dazu habe ich ein Sreenshot angehängt.

 

Nun brauche ich etwas Hilfe!

 

Ich bedanke mich schon im voraus für die hilfreichen Antworten.

 

Frank Schweizer

MSG Moto-Shop-Gera

 

dreambikeparts.de

Angehängte Bilder



#2 Marcel Schmidt

Marcel Schmidt

    SmartStore AG

  • Administrators
  • 103 Beiträge

Geschrieben: 10 August 2020 - 15:56

Hallo Frank,

 

hast du vor dem Update den Speicherort der Medien auf Dateisystem um verlagert? Dies ist definitiv zu empfehlen bei mehr als 500MB Medien, u.U. ist die Migration dort auf einen Fehler gestoßen. Solltest du den Speicherort noch auf Datenbank stehen haben, versuch das Update erneut, nachdem du den Speicherort umgestellt hast.

 

Solltest du weiterhin Probleme mit dem Account haben, kann es damit zusammen hängen, dass dein Account keine Berechtigungen zugeteilt bekommen hat. Schau mal hier: http://community.sma...gin#entry279887 und wende ggf. den Fix ( rar.gif  FixForPermissionMigrations.rar) auf deine DB an.

 

Beste Grüße


  • stefanmueller gefällt das

#3 msg team bauch

msg team bauch

    Newbie

  • Members
  • 5 Beiträge

Geschrieben: 12 August 2020 - 12:17

Guten Tag!

 

Vielen Dank für die schnelle 1. Antwort. Ich konnte nur noch nichts umsetzen. Leider bin ich immer noch dabei, den alten Shop aus der Datensicherung wieder zum Laufen zu bringen. Das kopieren der ganzen Dateien nimmt einige Zeit in Anspruch. Der erste Versuch der Wiederherstellung hat dann auch nicht funktionert und so versuche ich es wieder.

 

Mal sehen, wann ich wieder etwas zu diesem Thema schreiben kann.

 

Frank Schweizer

MSG Moto-Shop-Gera



#4 msg team bauch

msg team bauch

    Newbie

  • Members
  • 5 Beiträge

Geschrieben: 13 August 2020 - 09:24

Guten Tag! Es ist vollbracht. Ich habe die Datensicherung vom alten Shop wieder auf den Server kopiert und auch die Datenbank wiederhergestellt. Danach lief der alte Shop wieder und ich habe mich anmelden können. Im meinen Daten als Admin habe ich mal noch ein paar Eingaben vorgenommen, damit die Angaben komplett sind. Von diesem Shop habe ich die Datensicherung und Datenbanksicherung gemacht. Ah ja, in den Medieneinstellungen stand schon Dateisystem. Da habe ich nichts verändert. Jetzt mal schnell die Dateien vom Server gelöscht. App-Data- und Medienordner natürlich nicht! Dann ebenso schnell die Dateien von der neuen Version auf den Server kopiert. 

 

Ist es richtig, dass beim Kopieren der neuen Dateien die Frage kommt, dass Dateien schon existieren und diese überschrieben werden sollen? Das war der Fall. Ich habe mir aber nicht gemerkt oder aufgeschrieben, welche Dateien dies betrifft.

 

Jetzt warte ich erst einmal auf  Antwort, bevor ich weiteres schreibe.

 

Frank Schweizer



#5 Wolfgang Schmerge

Wolfgang Schmerge

    SmartStore AG

  • Administrators
  • 2153 Beiträge

Geschrieben: 13 August 2020 - 11:39

Hallo,

 

ja, die vorhandenen Dateien müssen überschrieben werden.

 

Liebe Grüße

 

Wolfgang 


Bleibt gesund!

 

Viele zusätzliche Smartstore Plugins gibt es im MARKETPLACE:
http://community.sma...dex.php?/files/

 

Hier geht es zu den Smartstore Videos:
Smartstore.NET Youtube-Channel
 

Die deutsche Smartstore Online-Dokumentation gibt es hier:
http://docs.smartsto...nutzer Handbuch

In dem folgenden BLOG findet man interessante Tipps & Tricks zum Thema "Smartstore":

http://community.sma...t-tipps-tricks/

 


#6 msg team bauch

msg team bauch

    Newbie

  • Members
  • 5 Beiträge

Geschrieben: 14 August 2020 - 11:24

Hallo!

 

So, es geht weiter. Die neue Version von Smartstore ist wieder auf dem Server und ich kann den Shop aufrufen. Es kommt die Login-Seite. Leider kann ich mich immer noch nicht als Admin anmelden. Schade!

 

Nun habe ich das Script "FixFor..." geladen. Das SQL Management Studio 2008 ist bei mir installiert und die Anmeldedaten für die Datenbank waren auch noch gespeichert. Ich habe mich angemeldet, meine Datenbank ausgwähltund mit der rechten Maustaste das Menü geöffnet. Danach habe ich ausgewählt: "Script für Datenbank als CREATE in". Ist das so richtig? In der Beziehung habe ich bei SQL keine Ahnung. Aber ich habe ja Datensicherungen und somit habe ich es einfach probiert. Danach ist eine Anmeldung trotzdem nicht möglich. War es so korrekt oder muss ich das Script anders ausführen?

 

Vielen Dank für die Updateanleitung. Diese ist bestimmt für die bezahlten Versionen gedacht (siehe Mail mit "App_Offline.htm  kopieren). Oder?

 

Frank Schweizer

MSG Moto-Shop-Gera



#7 msg team bauch

msg team bauch

    Newbie

  • Members
  • 5 Beiträge

Geschrieben: 19 August 2020 - 08:03

Guten Tag!

 

Nach mehreren Versuchen und ständigem hin und her der alten und der neuen Version ist ein Update nicht möglich. Die neue Version von Smartstore kann zwar gestartet werden, aber es ist keine Anmeldung als Admin möglich.

 

Wer hat denn schon mal die kostenlose Version auf 4.0.1 geupdatet?

 

Frank Schweizer