Inhalte aufrufen

Profilbild

Discount Badge is 0 when there is a value?


  • Bitte melden Sie sich an, um eine Antwort zu verfassen.
2 Antworten zu diesem Thema

#1 TripleNico

TripleNico

    Advanced Member

  • Members
  • 118 Beiträge

Geschrieben: 14 May 2020 - 12:29

So when i setup a product price like this:

Angehängte Datei  ProductPriceInfo.png   56.49K   0 Anzahl Downloads

 

Then i would expect a view something like this:

Angehängte Datei  ProductCorrectBadge.png   35.27K   0 Anzahl Downloads

 

Instead it show the view like this:

Angehängte Datei  ProductNulBadge.png   1.72K   0 Anzahl Downloads

 

So what is going wrong here?

 

FYI: This product was added and updated via de WebApi.

 

Second question, is it possible to disable the precentage that is placed before the product price? Don't even know why it is there?

Angehängte Datei  ProductDiscountPercentage.png   4.2K   0 Anzahl Downloads

 

Edit:

I just found out when it goes wrong; by changing the site language. If i set it to EN then everything displayes as it should but when i set in to NL (Our second language) then the value is 0. If you want to see/debug it, please PM me and i will send you the URL.



#2 TripleNico

TripleNico

    Advanced Member

  • Members
  • 118 Beiträge

Geschrieben: 15 May 2020 - 12:07

Solved the 0 part: It turns out that in the Dutch language the Products.SavingBadgeLabel localization was 0 instead of - {0} %

 

I also found a setting for the precentage sign but it seems that disabling this setting has no effect?



#3 Marcel Schmidt

Marcel Schmidt

    SmartStore AG

  • Administrators
  • 88 Beiträge

Geschrieben: 02 June 2020 - 15:54

HI,

 

thanks for the info, I fixed this ressource for NL translation in 3.2.2. 

 

Regarding your second question:

There is no option to disable '%' with one click, but you can find a easy solution here:

http://community.sma...n-before-price/

 

Best regards


  • TripleNico gefällt das