Inhalte aufrufen

Profilbild

Rewrite to HTTPS not completly working

transport transportzuschlag

  • Bitte melden Sie sich an, um eine Antwort zu verfassen.
7 Antworten zu diesem Thema

#1 nitware

nitware

    Advanced Member

  • Members
  • 31 Beiträge

Geschrieben: 21 March 2019 - 16:12

Hello Team,

 

After setting up URL rewrite with the code below in Web.config file, I noticed that blog, news, and forum menu item stop working. Other pages including contactus menu item works.

<rewrite>    
    <rules>    
        <rule name="Force HTTPS" enabled="true" >    
          <match url="(.*)" ignoreCase="false"/>
          <conditions>    
            <add input="{HTTPS}" pattern="off"/>    
          </conditions>    
          <action type="Redirect" url="https://{HTTP_HOST}/{R:1}" appendQueryString="true" redirectType="Permanent"/>    
      </rule>    
    </rules>    
  </rewrite>

What are my doing wrongly? What is the best way to redirect all HTTP traffic to HTTPS when using SmartStore.NET?

 

Regards,

Dan



#2 Murat Cakir

Murat Cakir

    SmartStore AG

  • Administrators
  • 1110 Beiträge

Geschrieben: 22 March 2019 - 00:33

Configuration > Stores > {Store} > SSL > Always use SSL (turn this on)


Murat Cakir
SmartStore AG


#3 nitware

nitware

    Advanced Member

  • Members
  • 31 Beiträge

Geschrieben: 27 March 2019 - 15:42

Thank you for your reply.

 

I've turned on SSL at Configuration > Stores > {Store} > SSL as you advised, but the problem still persists. All other URL works, except blog,news and forum. This is strange. Is there any other thing that I'm supposed to do?

 

I always get the following error:

The page isn’t redirecting properly
An error occurred during a connection to mail.test.com.
This problem can sometimes be caused by disabling or refusing to accept cookies.

All pages works perfectly when I disable the rewrite settings in web.config file. But once enabled, blog, forum and news pages fails with the error above. I've been on this for a while now.

 

Please assist.

 

Regards

Dan



#4 Murat Cakir

Murat Cakir

    SmartStore AG

  • Administrators
  • 1110 Beiträge

Geschrieben: 27 March 2019 - 19:06

Just disable or remove your rewrite rule in web.config. You don't need it: Always use SSL does the same.


Murat Cakir
SmartStore AG


#5 nitware

nitware

    Advanced Member

  • Members
  • 31 Beiträge

Geschrieben: 28 March 2019 - 16:37

Thank you very muchfor your assistance. But the settings that worked for me is located at Configuration > General and miscellaneous settings > Security settings  > Always use SSL. See the image below.

 

Angehängte Datei  Capture.PNG   220.59K   1 Anzahl Downloads

 

Thank you very much for your assistance.

 

Regards



#6 meerjungfrau

meerjungfrau

    Benutzer

  • Members
  • 26 Beiträge

Geschrieben: 06 November 2019 - 14:48

Hi everyone,

I have the same problem...

and was really happy to find that post...

 

 

I went to my admin panel Smartstore Net 3.1.5.

but under admin 

Admin/Setting/GeneralCommon

 

... so in german

Konfiguration > Allgemeine Einstellungen > Sicherheit

I find the menue but in my case there isnt any box "with always use ssl" that I can mark?

 

Do you need a screenshot?

 

Thanks for helping 

kind regards

Petra


liebe Grüße
Petra

#7 Murat Cakir

Murat Cakir

    SmartStore AG

  • Administrators
  • 1110 Beiträge

Geschrieben: 11 November 2019 - 19:44

Option has been meanwhile moved to Configuration > Stores > [Store] > SSL > Always use SSL.


Murat Cakir
SmartStore AG


#8 meerjungfrau

meerjungfrau

    Benutzer

  • Members
  • 26 Beiträge

Geschrieben: 11 November 2019 - 22:13

Hi,

thanks 

problem is solved


liebe Grüße
Petra


Auch markiert mit einem oder mehrerer dieser Schlüsselwörter: transport, transportzuschlag