Inhalte aufrufen

Profilbild

Issue with Salutation/Country in Email and PDF Order


4 Antworten zu diesem Thema

#1 CompleteCoders

CompleteCoders

    Advanced Member

  • Members
  • 68 Beiträge

Geschrieben: 02 October 2018 - 18:35

I posted this as an issue but it closed saying the feature exists already.
 

 

In the General Settings -> Company tab the user should not be forced to enter a Salutation or Country if they do not want to. The user should be allowed to leave these blank.

This is problematic for a client who doesn't want to add a Mr/Mrs to the order form print screen or the email templates. Same if they don't want to add their country.

 

Response:

Can be configured in Configuration > General > Customer settings

 

 

From what I can tell the settings in Configuration > General > Customer settings does not affect the Salutation/Company showing up on Email and the PRF version of the Order documents.

 

I can go into the Settings All Settings section and blank them out but they will always come back anytime the user saves because the drop downs auto-select the first value.

 

There is no setting that I can see that will stop the values from appearing in these two places.  

 



#2 Jannis_

Jannis_

    SmartStore Team

  • Administrators
  • 28 Beiträge

Geschrieben: 05 October 2018 - 11:19

Every Customer needs to add a Country so the Shipping is right, thats why you can't leave the option for Countrys blank.

 

I reproduced the problem and forwarded it to our Developers.

 

You can follow these steps to solve your problem in the meantime. Configuration > Settings > Customer settings > Addresses and write into the space next to Salutations. Press "alt" on your keyboard and hold it then you need to press 255 on your numpad and put this ", Mr., Mrs." behind the protected blank then save.



#3 Marcus Gesing

Marcus Gesing

    SmartStore AG

  • Administrators
  • 3305 Beiträge

Geschrieben: 05 October 2018 - 12:42

Are we talking about customer or merchant settings?
Configuration > Settings > General and miscellaneous settings > Company
Configuration > Settings > Customer settings > Registration
or
Configuration > Settings > Customer settings > Addresses?

Schöne Grüße aus Düsseldorf,
Marcus Gesing


#4 CompleteCoders

CompleteCoders

    Advanced Member

  • Members
  • 68 Beiträge

Geschrieben: 16 October 2018 - 15:53

Configuration > Settings > General and miscellaneous settings > Company

 

The two fields on this page appear cannot be blanked out.



#5 Marcus Gesing

Marcus Gesing

    SmartStore AG

  • Administrators
  • 3305 Beiträge

Geschrieben: 16 October 2018 - 17:09

Has been fixed meanwhile.


Schöne Grüße aus Düsseldorf,
Marcus Gesing




Auf dieses Thema antworten