Inhalte aufrufen

Profilbild

Serverfehler in der Anwendung /. Ungültiger IL-Bereich.

Serverfehler

  • Bitte melden Sie sich an, um eine Antwort zu verfassen.
1 Antwort zu diesem Thema

#1 shopuser

shopuser

    Benutzer

  • Members
  • 28 Beiträge

Geschrieben: 13 September 2017 - 10:57

Hallo zusammen,
nach monatelangem Serverbetrieb ohne Probleme, läuft die Website seit heute nicht mehr. Folgende Fehlermeldung hat mir der Provider gepostet. Ein Neustart der Anwendung im IIS hat nichts gebracht. Die smartstore Version ist 2.1.1.0. Hat jemand von Euch eine Idee, an was es liegen könnte?

 

Danke für Eure Hilfe, Franz

 

Hier der Fehlertext:

 

Serverfehler in der Anwendung /. 

Ungültiger IL-Bereich.

Beschreibung: Unbehandelte Ausnahme beim Ausführen der aktuellen Webanforderung. Überprüfen Sie die Stapelüberwachung, um weitere Informationen über diesen Fehler anzuzeigen und festzustellen, wo der Fehler im Code verursacht wurde.

Ausnahmedetails: System.BadImageFormatException: Ungültiger IL-Bereich.

Quellfehler:
 

Beim Ausführen der aktuellen Webanforderung wurde einen unbehandelte Ausnahme generiert. Informationen über den Ursprung und die Position der Ausnahme können mit der Ausnahmestapelüberwachung angezeigt werden.

Stapelüberwachung:
 

[BadImageFormatException: Ungültiger IL-Bereich.]
   SmartStore.Admin.Infrastructure.DependencyRegistrar..ctor() +0

[TargetInvocationException: Ein Aufrufziel hat einen Ausnahmefehler verursacht.]
   System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandleInternal& ctor, Boolean& bNeedSecurityCheck) +0
   System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark& stackMark) +119
   System.RuntimeType.CreateInstanceDefaultCtor(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark& stackMark) +247
   System.Activator.CreateInstance(Type type, Boolean nonPublic) +83
   System.Activator.CreateInstance(Type type) +11
   SmartStore.Core.Infrastructure.SmartStoreEngine.RegisterDependencies() +515
   SmartStore.Core.Infrastructure.SmartStoreEngine.Initialize() +15
   SmartStore.Core.Infrastructure.EngineContext.Initialize(Boolean forceRecreate, IEngine engine) +72
   SmartStore.Web.MvcApplication.Application_Start() +149

[HttpException (0x80004005): Ein Aufrufziel hat einen Ausnahmefehler verursacht.]
   System.Web.HttpApplicationFactory.EnsureAppStartCalledForIntegratedMode(HttpContext context, HttpApplication app) +10063289
   System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers) +118
   System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context) +173
   System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context) +336
   System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext) +296

[HttpException (0x80004005): Ein Aufrufziel hat einen Ausnahmefehler verursacht.]
   System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +10044576
   System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +95
   System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +254


#2 shopuser

shopuser

    Benutzer

  • Members
  • 28 Beiträge

Geschrieben: 13 September 2017 - 12:50

Ein zweiter Neustart hat dann doch geholfen, der Erste wurde durch den Betreiber gemacht und hat nichts gebracht. Wenn man nicht alles selber macht...;-)

 

Die datei web.config für einen Neustart kurz umbenannt und das war es.

 

Danke und noch eine schönen Tag, Franz




Auch markiert mit einem oder mehrerer dieser Schlüsselwörter: Serverfehler