Inhalte aufrufen

Profilbild

Site down after theme configuratoin (link color)


5 Antworten zu diesem Thema

#1 Litaly

Litaly

    Member

  • Members
  • PunktPunkt
  • 12 Beiträge

Geschrieben: 05 September 2017 - 22:15

Hi

 

Now my site is down with ERR_CONNECTION_RESET (OR ERROR 503)

This problem appears, when I was changing Flex Theme in admin site, link-color. I choosed color with number b00000 (without#). Then site stuck, trying to configure theme and after that crashed. I think this happened, because colour b000000 not correct for smartsore. Thats why site have some cyclic errors (this info from administration of hosting smarterasp).

How can i fix this problem, where can I change theme configuration (link color).

 

I will be appreciate for any help.



#2 Litaly

Litaly

    Member

  • Members
  • PunktPunkt
  • 12 Beiträge

Geschrieben: 06 September 2017 - 06:11

More information from the server.

Application pool recycled

9/5/2017 9:52:05 pm application pool is being automatically disabled due to a series of failures in the process(es) serving that application pool. 
9/5/2017 9:52:05 pm a process serving application pool suffered a fatal communication error with the windows process activation service. the process id was '43608'. the data field contains the error number. 
9/5/2017 9:51:20 pm a process serving application pool suffered a fatal communication error with the windows process activation service. the process id was '13768'. the data field contains the error number. 
9/5/2017 9:50:28 pm a process serving application pool suffered a fatal communication error with the windows process activation service. the process id was '33900'. the data field contains the error number. 



#3 Litaly

Litaly

    Member

  • Members
  • PunktPunkt
  • 12 Beiträge

Geschrieben: 06 September 2017 - 06:38

The problem fixed. b000000 is incorrect color, that was deleted from the database using sql studio and changed to $gray

Now site is ok

Be carefull configurating theme in admin site



#4 Murat Cakir

Murat Cakir

    SmartStore AG

  • Administrators
  • 1002 Beiträge

Geschrieben: 06 September 2017 - 17:14

Actually this has been fixed in V3.0.1. Which version do you use?


Murat Cakir
SmartStore AG


#5 Litaly

Litaly

    Member

  • Members
  • PunktPunkt
  • 12 Beiträge

Geschrieben: 11 September 2017 - 11:43

My version is 3.0.2.0 (not upgraded from previous), it's clear instalation.



#6 Murat Cakir

Murat Cakir

    SmartStore AG

  • Administrators
  • 1002 Beiträge

Geschrieben: 11 September 2017 - 18:12

It seems that the SASS compiler does not tolerate some invalid input and - instead of gracefully handling such errors - brutally crashes and tears the whole application with it. Unfortunately there's nothing we can do about it, because the SASS compiler is an external low-level component. We could however do some pre-validation, which is a very tedious task though... plenty of code and extremely difficult to reliably identify (in)valid input because of the very dynamic nature of SASS.


Murat Cakir
SmartStore AG




Auf dieses Thema antworten