Inhalte aufrufen

Profilbild

Https und TaskScheduler error

HTTPS TaskScheduler

  • Bitte melden Sie sich an, um eine Antwort zu verfassen.
Keine Antworten zum Thema vorhanden

#1 PeterNZ

PeterNZ

    Advanced Member

  • Members
  • 34 Beiträge

Geschrieben: 27 August 2017 - 23:48

Hi community,

 

ich dachte ich berichte mal was mir untergekommen ist. Ich habe kuerzlich meinen shop auf HTTPS umgestellt. nach einer aendrung in der web.config hat alles funktioniert. Dachte ich mir. Dann kam das problem auf, dass ich keine kopie der kundenbestellungen mehr per email bekam. In mir kam auch der verdacht auf, dass eventuell meine kunden keine emails mehr bekamen. Kann man irgendwo sehen ob emails verschickt wurden?

 

Ich hab dann in den system logs rumgegraben und das gefunden:

"Error while calling TaskScheduler endpoint 'http://www. domainname/TaskScheduler/Sweep'. HTTP 404, Not Found" in SmartStore.Services.Tasks.DefaultTaskScheduler. Was mir verdaechtig vorkam war die URL http://www. domainname/TaskScheduler/Sweep die kein HTTPS benutzte. Ich bin dann im log zurueck zum ersten erscheinen des fehlers gegangen und es war in dem zeitbereich in dem ich HTTPS eingerichtet hatte.

 

Ich habe dann ein setting in Settings|General and miscellaneous settings|Security settings gefunden was sagt "Always use SSL". Ich habe das enabled, die app restarted und .... genau der gleiche fehler wie vorher.

 

Also weiter gogoeln. Dann bin ich auf etwas gestossen was sagte man muss unter "Mein shop" eine korrekte URL eingeben. Ich also in Configuration|Stores gegangen, meine shop geoeffnet und siehe da, ne weitere checkbox mit SSL. Ich habe dann diese box enabled und die URL in HTTPS://.... geaendert. Restart application und siehe da, anstatt "Initialized TaskScheduler with base url 'http://www. domainname/TaskScheduler'" zeigt das log nun "Initialized TaskScheduler with base url 'https://www. domainname/TaskScheduler'" und keine fehlermeldungen mehr. Ein test hat ergeben, dass emails nun verschickt werden.

 

Ich finde die doku ist im bereich SSL und HTTPS etwas sehr duenn. Ich finde es auch etwas verwirrend das an zwei stellen eine SSL parameter aktiviert werden kann.

 

Eventuell hilft das jemand in der zukunft. Kommentare willkommen.

 

Cheers

 

Peter