Inhalte aufrufen

Profilbild

All of a sudden plugins stopped getting loaded

plugins

2 Antworten zu diesem Thema

#1 Kushil

Kushil

    Newbie

  • Members
  • Punkt
  • 4 Beiträge

Geschrieben: 02 March 2017 - 09:47

Hi

I have two running SmartStore instances. One is my Dev environment and second is my Test environment.Both environments have been installed from the same build/source. All of a sudden my Dev environment's Facebook and Twitter login buttons disappeared. Then I checked Admin Console's plugins page. I saw all the plugins in it have disappeared too. Its just showing "Install or update plugins" message. Since my Test environment works fine I copied everything inside its plugins folder to my Dev environment's plugins folder (I deleted everything inside the destination before copying the files) . I restarted the SmartStore,  App pool, IIS and also the whole computer. But plugins are still not getting loaded. I can confirm everything in the plugins folder are identical to my working Test environment's plugins folder. I also can confirm plugin list in InstalledPlugins.txt in App_Data is also identical.

I debugged the problem. I found that _referencedPlugins field in SmartStore.Core's PluginManager class is empty. That is not getting populated. Could you please tell me at which point "Initialize" static method getting called to populate _referencedPlugins field? How do I debug inside that initialize method to see any problems? At the moment I cannot see its getting called anywhere. Please help!

Thanks in advance

Kush



#2 Marcus Gesing

Marcus Gesing

    SmartStore AG

  • Administrators
  • 3018 Beiträge

Geschrieben: 02 March 2017 - 15:58

You cannot debug "Initialize" because it is a PreApplicationStartMethod. In my case an empty plugin list problem was solved by deleting temporary ASP.NET files under %WINDIR%\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root

Schöne Grüße aus Düsseldorf,
Marcus Gesing


#3 Kushil

Kushil

    Newbie

  • Members
  • Punkt
  • 4 Beiträge

Geschrieben: 02 March 2017 - 23:10

Hi Marcus

Thanks very much for your response. I deleted everything there as per your instructions. I restarted everything and tried. But Admin Console's plugin page still does not load plugins. I can see the newly created sub folder inside %WINDIR%\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root folder contains all the plugins in the name of such as "SmartStore.FacebookAuth.dll" and "SmartStore.FacebookAuth.dll.delete". I also checked the trace.axd of the site after the restart. But I cannot see any errors in it. Any help would be appreciated to troubleshoot this issue.





Auf dieses Thema antworten



  

Auch markiert mit einem oder mehrerer dieser Schlüsselwörter: plugins