Inhalte aufrufen

Profilbild

Attribute Fehler bei Bildanzeige

Bildanzeige Attribute Fehler

  • Bitte melden Sie sich an, um eine Antwort zu verfassen.
5 Antworten zu diesem Thema

#1 Golfmaster3000

Golfmaster3000

    Benutzer

  • Members
  • 29 Beiträge

Geschrieben: 05 September 2016 - 14:06

Hallo SmartStore.NET community

 

ich habe heute einen mächtigen und merkwürdigen Fehler gefunden. Ich habe vor einer Woche alle Variationen unserer Schuhe mit Farbe und Größe eingerichtet. Dann sehe ich aber das teilweise bei allen verschiedenen Kominationen der Varianten ein Schuh Bild dabei ist was gar nicht dort sein sollte. z.B bei dem weißen Schuh ist , die weiße Abbildung da und eine Abbildung eines roten Schuhs.

 

Manchmal werden auch die Bilder gar nicht anzeigt die ich ausgewählt habe, sondern einfach das Bild von Variante 1.

Hier eine Bildveranschaulichung des Problems:

 

[Bild1]

w7ts3plr.jpg

 

 

 

Wie sie sehen Brillant Nero ausgewählt Größe 37, und komischerweise ist dort ein roter Schuh der dort nicht sein sollte.

 

Jetzt gehen wir natrülich mal in die Attribute rein bei genau diesem Schuh:

 

[Bild2]

 

qjr7hc9p.jpg

 

 

Hier sehen wir dann natürlich nur die schwarze richtige Variante des Bilds mit hacken und nicht den roten, was macht nun der rote da? Und wieso ist das fast überall so und bei manchen nicht? Ist das ein großer Fehler? Kann man diesen überhaupt heben? wenn nein dann kann ich keine Schuhe mehr anbieten.. >.<

 

Webseite: http://golfmaul.de/h...amen-golfschuhe

 

Hoffe auf Hilfe, ich verzweifle hier gerade.

 

Mit freundlichen Grüßen

Golfmaster3000

 

 

 


  • GalenKa und Brantot gefällt das

#2 Wolfgang Schmerge

Wolfgang Schmerge

    SmartStore AG

  • Administrators
  • 1766 Beiträge

Geschrieben: 05 September 2016 - 14:17

Hallo Golfmaster3000,

 

hast du evtl. bei den betroffenen Produkten irgendwann mal Attribut-Kombinationen gelöscht und wieder neu eingerichtet?
 

Kennst du dich mit SQL-Datenbanken aus?

Wenn ja schau mal bitte in der Tabelle "[dbo].[ProductVariantAttributeCombination]" nach

ob bei den betroffenen Produkten die richtigen Produktbilder zugeordnet wurden "[AssignedPictureIds]".

 

Liebe Grüße

 

Wolfgang


Viele zusätzliche SmartStore.NET Plugins gibt es im MARKETPLACE:
http://community.sma...dex.php?/files/

 

Die deutsche SmartStore.NET Online-Dokumentation gibt es hier:
http://docs.smartsto...display/smnetde

In dem folgenden BLOG findet man interessante Tipps & Tricks zum Thema "SmartStore.NET":

http://community.sma...t-tipps-tricks/


#3 Murat Cakir

Murat Cakir

    SmartStore AG

  • Administrators
  • 1015 Beiträge

Geschrieben: 05 September 2016 - 16:15

Unter Konfiguration > Einstellungen > Katalog > Produktdetail findet sich die - zugegeben etwas merkwürdige :blush:  - Option "Anzahl, ab der Bilder nur noch bei Variantenwechsel angezeigt werden". Die Voreinstellung ist 6. D.h.: bei weniger als 6 Produkt-Bildern werden bei einem Varianten-Wechsel nach wie vor alle verfügbaren Produkt-Bilder angezeigt; nicht nur die dem Varianten zugeordneten. Um also zu erzwingen, dass bei einem Varianten-Wechsel grundsätzlich alle anderen Bilder (also jene, die nichts mit dem Varianten zu tun haben) ausgeblendet werden, sollte man diesen Wert auf 1 runterschrauben.


Murat Cakir
SmartStore AG


#4 Golfmaster3000

Golfmaster3000

    Benutzer

  • Members
  • 29 Beiträge

Geschrieben: 12 September 2016 - 11:07

Hallo Golfmaster3000,

 

hast du evtl. bei den betroffenen Produkten irgendwann mal Attribut-Kombinationen gelöscht und wieder neu eingerichtet?
 

Kennst du dich mit SQL-Datenbanken aus?

Wenn ja schau mal bitte in der Tabelle "[dbo].[ProductVariantAttributeCombination]" nach

ob bei den betroffenen Produkten die richtigen Produktbilder zugeordnet wurden "[AssignedPictureIds]".

 

Liebe Grüße

 

Wolfgang

 Leider kenn ich mit SQL nicht aus .. :/ Ja die Kombinationen wurden einmal komplett gelöscht und die Attribute angepasst. Danach hab ich alle Kombinationen neu erstellen lassen. Aber es sind alle von dem roten Schuh fast betroffen. :/

 

Unter Konfiguration > Einstellungen > Katalog > Produktdetail findet sich die - zugegeben etwas merkwürdige :blush:  - Option "Anzahl, ab der Bilder nur noch bei Variantenwechsel angezeigt werden". Die Voreinstellung ist 6. D.h.: bei weniger als 6 Produkt-Bildern werden bei einem Varianten-Wechsel nach wie vor alle verfügbaren Produkt-Bilder angezeigt; nicht nur die dem Varianten zugeordneten. Um also zu erzwingen, dass bei einem Varianten-Wechsel grundsätzlich alle anderen Bilder (also jene, die nichts mit dem Varianten zu tun haben) ausgeblendet werden, sollte man diesen Wert auf 1 runterschrauben.

Kam mir auch logisch vor leider hat es das Problem nicht behoben :( Habs auf 1 runtergeschraubt aber der rote Schuh ist immernoch da >.<

 

LG

Golfmaster3000



#5 Wolfgang Schmerge

Wolfgang Schmerge

    SmartStore AG

  • Administrators
  • 1766 Beiträge

Geschrieben: 12 September 2016 - 11:30

Hallo Golfmaster3000,

 

du könntest ein Support-Ticket buchen.

http://community.sma...&module=support

 

Dann würden wir uns das Problem direkt in deinem Shop ansehen.

 

Liebe Grüße

 

Wolfgang


Viele zusätzliche SmartStore.NET Plugins gibt es im MARKETPLACE:
http://community.sma...dex.php?/files/

 

Die deutsche SmartStore.NET Online-Dokumentation gibt es hier:
http://docs.smartsto...display/smnetde

In dem folgenden BLOG findet man interessante Tipps & Tricks zum Thema "SmartStore.NET":

http://community.sma...t-tipps-tricks/


#6 Golfmaster3000

Golfmaster3000

    Benutzer

  • Members
  • 29 Beiträge

Geschrieben: 27 September 2016 - 10:39

Hallo Golfmaster3000,

 

du könntest ein Support-Ticket buchen.

http://community.sma...&module=support

 

Dann würden wir uns das Problem direkt in deinem Shop ansehen.

 

Liebe Grüße

 

Wolfgang

Was ist ein Support Ticket? Eine einmalige Hilfe für dieses Problem? Weil das Paket mit dem Support kann unsere Kleinfirma sich nicht leisten.




Auch markiert mit einem oder mehrerer dieser Schlüsselwörter: Bildanzeige, Attribute, Fehler