Inhalte aufrufen

Profilbild

Installation

newsletterpreise preise

  • Bitte melden Sie sich an, um eine Antwort zu verfassen.
11 Antworten zu diesem Thema

#1 Mario M.

Mario M.

    Newbie

  • Members
  • 6 Beiträge

Geschrieben: 05 October 2014 - 00:31

Ich habe folgendes Problem ...

 

nach Aufruf von http://localhost/smartstore bekomme ich folgende Meldung

 

Konfigurationsfehler

Beschreibung: Fehler beim Verarbeiten einer Konfigurationsdatei, die für diese Anforderung erforderlich ist. Überprüfen Sie die unten angegebenen Fehlerinformationen, und ändern Sie die Konfigurationsdatei entsprechend. 

Parserfehlermeldung: Unbekanntes targetFramework-Attribut. Beachten Sie bei Attributnamen die Groß-/Kleinschreibung.

Quellfehler: 
 

Zeile 103: <sessionState mode="InProc" />
Zeile 104: <trace enabled="false" localOnly="true" pageOutput="true" requestLimit="40" />
Zeile 105: <compilation targetFramework="4.5" batch="true" optimizeCompilations="false">
Zeile 106: <assemblies>
Zeile 107: <add assembly="System.Web.Abstractions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />

Quelldatei: C:\inetpub\wwwroot\web.config    Zeile: 105 
 

Versionsinformationen: Microsoft .NET Framework-Version:2.0.50727.5485; ASP.NET-Version:2.0.50727.5483

 

 

 

Wo liegt mein Fehler ?? 



#2 Marcus Gesing

Marcus Gesing

    SmartStore AG

  • Administrators
  • 3540 Beiträge

Geschrieben: 05 October 2014 - 12:09

Bitte mal folgendes probieren.


Schöne Grüße aus Düsseldorf,
Marcus Gesing


#3 Mario M.

Mario M.

    Newbie

  • Members
  • 6 Beiträge

Geschrieben: 07 October 2014 - 14:11

HTTP-Fehler 500.19 - Internal Server Error Auf die angeforderte Seite kann nicht zugegriffen werden, da die zugehörigen Konfigurationsdaten für die Seite ungültig sind.
Detaillierte Fehlerinformationen:
Modul    IIS Web Core Benachrichtigung    BeginRequest Handler    Noch unbestimmt Fehlercode    0x80070021 Konfigurationsfehler    Dieser Konfigurationsabschnitt kann in diesem Pfad nicht verwendet werden. Dies ist der Fall, wenn der Abschnitt auf übergeordneter Ebene gesperrt ist. Die Sperrung erfolgt standardmäßig (overrideModeDefault="Deny") oder wird explizit mit einem location-Tag mit overrideMode="Deny" oder der Legacyeinstellung allowOverride="false" festgelegt. Konfigurationsdatei    \\?\C:\inetpub\wwwroot\smartstore\web.config
Angeforderte URL    http://localhost:80/smartstore Physischer Pfad    C:\inetpub\wwwroot\smartstore Anmeldemethode    Noch unbestimmt Benutzeranmeldung    Noch unbestimmt
 
Konfigurationsquelle: 137: <validation validateIntegratedModeConfiguration="true" />
138: <handlers>
139: <remove name="ExtensionlessUrlHandler-ISAPI-4.0_32bit" />

 

 

Ich kann machen was ich will ... komme leider nicht weiter :(



#4 Murat Cakir

Murat Cakir

    SmartStore AG

  • Administrators
  • 1110 Beiträge

Geschrieben: 08 October 2014 - 22:19

Bitte mal das .NET Framework 4.5 installieren.


Murat Cakir
SmartStore AG


#5 Mario M.

Mario M.

    Newbie

  • Members
  • 6 Beiträge

Geschrieben: 09 October 2014 - 10:17

Das habe ich schon ... alle herunterladbaren und installierbaren Versionen ... von .NET Framework und MS SQL 2008 und 2012 und MS VB C++ und MS Azure und MS ASP.NET ... 

 

wieso gestaltet sich das so schwierig :( ... 



#6 Guest_sanimirza_*

Guest_sanimirza_*
  • Guests

Geschrieben: 05 December 2014 - 12:16

Hi Peter,
 
wir entwickeln auch. unser Shop hat auch schon einige kleine Änderungen wie z.B. unsere Links wie Impressum usw. sind in Deutsch. Auch die Suche haben wir erweitert.
 
Wir können auch aus fast allen Programmen Datenimport machen.


#7 cigarre

cigarre

    Neuer Benutzer

  • Members
  • 12 Beiträge

Geschrieben: 30 January 2015 - 20:04

Hallo

 

Nach dem Aufruf zur Installation http://localhost/smartstore erscheint folgende Fehlermitteilung - siehe Screenshot.

 

Ich habe alle erforderlichen Programme auf dem neuesten Stand.

 

Ich bitte hier um Hilfe. Danke!

Angehängte Bilder



#8 Marcus Gesing

Marcus Gesing

    SmartStore AG

  • Administrators
  • 3540 Beiträge

Geschrieben: 30 January 2015 - 22:30

In der Datei App_Data/Settings.txt muss unter "DataConnectionString" der Connection-String zur Datenbank eingetragen sein:
AppVersion: 2.1.1.0
DataProvider: sqlserver
DataConnectionString: Data Source=MySqlServer;Initial Catalog=MyDatabase;Integrated Security=False;Persist Security Info=False;User ID=MyUser;Password=MyPassword;Enlist=False;MultipleActiveResultSets=True

  • cigarre gefällt das

Schöne Grüße aus Düsseldorf,
Marcus Gesing


#9 cigarre

cigarre

    Neuer Benutzer

  • Members
  • 12 Beiträge

Geschrieben: 31 January 2015 - 11:47

In dem Verzeichnis App_Data ist die Datei "Settings.txt" nicht vorhanden ?

 

Was nun ?

 

MfG



#10 Marcus Gesing

Marcus Gesing

    SmartStore AG

  • Administrators
  • 3540 Beiträge

Geschrieben: 02 February 2015 - 12:58

Dann wurde noch nicht installiert. Sprich Anwendung wurde noch nie gestartet. Bitte mal im Browser aufrufen. Dann erscheint die Seite mit der Installation und die legt die Settings.txt an.


Schöne Grüße aus Düsseldorf,
Marcus Gesing


#11 cigarre

cigarre

    Neuer Benutzer

  • Members
  • 12 Beiträge

Geschrieben: 02 February 2015 - 13:47

Hallo

Ich habe es so verstanden, das die Installation mit dem Aufruf "http://localhost/smartstore" gestartet wird.

Es erscheint aber keine Seite mit der Installation, sondern es kommt besagte Fehlermeldung.

Was muß ich für den korrekten Installationsaufruf im Browser eingeben?

Vielen Dank im voraus !



#12 Marcus Gesing

Marcus Gesing

    SmartStore AG

  • Administrators
  • 3540 Beiträge

Geschrieben: 02 February 2015 - 16:44

Was muß ich für den korrekten Installationsaufruf im Browser eingeben?

 

Jene URL, an die Sie die Seite im IIS gebunden haben. Sie finden den Link auch im IIS rechts unter "Website durchsuchen".


  • cigarre gefällt das

Schöne Grüße aus Düsseldorf,
Marcus Gesing



Auch markiert mit einem oder mehrerer dieser Schlüsselwörter: newsletterpreise, preise